linktree Atrinik.org - Multiplayer Online Role Playing Game  >  Community  >  Support
linktree Topic: server compile : Can't open bmaps file
Pages: 1 [2]   Go Down
  Print  
Author Topic: server compile : Can't open bmaps file  (Read 6586 times)
0 Members and 1 Guest are viewing this topic. Bookmarked by 0 members.
Offline Sonic-NKT
Posts: 3
« Reply #15 on: March 21, 2014, 11:53:42 am »

First: Thanks for the fast reply...

Here is the content of my links.txt:
Code: inactive:javascript:void(0);

/usr/bin/gcc  -fPIC    -shared -Wl,-soname,libplugin_python.so -o libplugin_python.so CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_archetype.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_map.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_object.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_party.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_player.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/atrinik_region.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/attr_list.c.o CMakeFiles/plugin_python.dir/src/plugins/plugin_python/plugin_python.c.o /usr/lib/python3.2/config/libpython3.2.so -Wl,-rpath,/usr/lib/python3.2/config


So it seems to be linked to python 3.2 instead of 3.3?
 Logged
Offline Cleo
Developer
Alex Tokar

Posts: 580
Gender: Male
« Reply #16 on: March 21, 2014, 12:51:19 pm »

Hi,

I think the problem might be in our makefile for the project; from what I can see, you're using latest stable version of Atrinik (3.0), and at the time of its release, the latest version of Python was 3.2, and it's not actually looking for 3.3 at all.

I suggest replacing the following line in CMakeLists.txt:

Code: [Select]
set(Python_ADDITIONAL_VERSIONS 3.2 3.1 3.0 2.7 2.6)


with:

Code: [Select]
set(Python_ADDITIONAL_VERSIONS 3.3 3.2 3.1 3.0 2.7 2.6)


Then running:

Code: [Select]
rm CMakeCache.txt && cmake . && make


If that doesn't work, try forcing Python 2.7 (which is also compatible with Atrinik IIRC) instead, like this:

Code: [Select]
set(Python_ADDITIONAL_VERSIONS 2.7 3.2 3.1 3.0 2.6)


Thanks,
Cleo
 Logged
Offline Sonic-NKT
Posts: 3
« Reply #17 on: March 21, 2014, 01:39:07 pm »

Thank you very much...
adding the python 3.3 to CMakeLists.txt fixed it.
(I still edited the build.config)
compile went fine and server is now running without errors, i only tried tried it a few seconds but the first npc who didnt talk to me before now answered fine.
Will test the whole tutorial island later.

Well Thanks again for the quick help. You could add this info to the pinned thread for all others :)
 Logged
Pages: 1 [2]   Go Up
  Print  
 
Jump to: