linktree Atrinik.org - Multiplayer Online Role Playing Game  >  Community  >  Support
linktree Topic: Problems with server with 3.0
Pages: [1]   Go Down
  Print  
Author Topic: Problems with server with 3.0  (Read 3173 times)
0 Members and 1 Guest are viewing this topic. Bookmarked by 0 members.
Offline Anarion
Posts: 11
Gender: Male
« on: August 10, 2011, 01:28:33 am »

Cant access server, seems its not compatible with new client
 Logged
Online Cleo
Developer
Alex Tokar

Posts: 580
Gender: Male
« Reply #1 on: August 10, 2011, 01:58:23 am »

Where did you install the client from and what OS are you using?
 Logged
Offline Anarion
Posts: 11
Gender: Male
« Reply #2 on: August 10, 2011, 02:10:29 am »

Downloaded and compilied source, using Linux, debian system 64bit.    Everything went smooth, no errors or nothing, and game itself startups fine.   Just cant get past the server issue.  Ill post what Im getting:

Trying Server Atrinik Main Server (13327)...
Connected.  Exchange version.
This Atrinik server is outdated and incompatible with your client's version. 
Try another server.

Im not an expert now, so if you got any majorly technical questions you might have to dumb them down a bit.
« Last Edit: August 10, 2011, 02:14:39 am by cphayes0882 »  Logged
Online Cleo
Developer
Alex Tokar

Posts: 580
Gender: Male
« Reply #3 on: August 10, 2011, 02:15:28 am »

You haven't answered the question of where you downloaded it from though. The daily packages, and the Bazaar repository, are development versions, and often incompatible with the main server, which is probably your issue. Since you are on Debian, you can follow the installation instructions here, with no compilation necessary:

https://www.atrinik.org/page/installing_atrinik_client
 Logged
Offline Anarion
Posts: 11
Gender: Male
« Reply #4 on: August 10, 2011, 02:40:41 am »

Doh,  thanks Cleo for the quick response.     That was my problem, missed over the Debian section and went straight to compiling the daily.   Course now when I install the deb package and try to run the game,  I get nothing.  Tried from terminal, got this :

[Info] 
SIGSEGV received.
Aborted

Whew,    Im determined to solve this problem :p
 Logged
Online Cleo
Developer
Alex Tokar

Posts: 580
Gender: Male
« Reply #5 on: August 10, 2011, 02:46:28 am »

Unfortunately the official 3.0 client is unable to handle settings added in the development version, so it SIGSEGVs... To fix the problem, run this from terminal:

Quote
rm -rf ~/.atrinik/3.0
 Logged
Offline Anarion
Posts: 11
Gender: Male
« Reply #6 on: August 10, 2011, 02:52:57 am »

I forgot all about the config folder.    Thanks a million cleo, solved my problem.   Up and running. 
 Logged
Online Cleo
Developer
Alex Tokar

Posts: 580
Gender: Male
« Reply #7 on: August 10, 2011, 02:54:14 am »

Glad to help. :)
 Logged
Pages: [1]   Go Up
  Print  
 
Jump to: